Atualizando os repositórios do Debian Lenny

Um ano após  o lançamento do Debian 6 (Squeeze) os repositórios da versão anterior (Lenny) foram desativados ( http://www.debian.org/News/2012/20120209 ), mas ainda existe uma grande base instalada e que frequente precisa de manutenção e adição de pacotes. Se você tem um servidor com esta distribuição, deve estar recebendo os seguintes erros ao executar apt-get:

W: Failed to fetch http://ftp.debian.org/debian/dists/lenny/contrib/source/Sources 404 Not Found [IP: 130.89.148.12 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.

Para solucionar o problema é necessário atualizar o arquivo /etc/apt/sources.list com os seguintes novos repositórios:

deb http://archive.debian.org/debian/ lenny main non-free contrib
deb-src http://archive.debian.org/debian/ lenny main non-free contrib
deb http://archive.debian.org/debian-security/ lenny/updates main contrib non-free
deb-src http://archive.debian.org/debian-security/ lenny/updates main contrib non-free
deb http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
deb http://archive.debian.org/debian-backports lenny-backports main contrib non-free

Salve o arquivo e então execute: apt-get update

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s